To stop the reverse engineering of script apps, many developers encode their code with instruments such as ionCube PHP Encoder in order to make it human unreadable. The latter is valid for paid applications in particular, since anyone would be able to use and modify the unencrypted code without paying the required license fees. In case you buy web software encrypted with ionCube PHP Encoder, you will be able to use it without any problems as long as an instrument known as ionCube Loader is available on the website hosting server. This loader allows you to execute encrypted files and you'll often find it among the prerequisites for a given script app to be installed. Because the encoded files are already precompiled, they're ordinarily executed more rapidly and this can improve the general speed of your website.
IonCube in Website Hosting
IonCube Loader comes with all website hosting packages which we provide, so when you need it in order to set up and run some script app that requires it, you can activate it with a single click inside the Advanced section of the Hepsia Control Panel. As you are able to switch the PHP version that is active for your account in the same section, you'll have to enable the instrument for each new version that you set. When you are more skillful, you are able to use a php.ini file in a domain or subdomain folder and set the PHP version as well as the status of ionCube Loader for this particular website only, without affecting the entire account. This way you are able to run both new and older script applications for multiple sites in the same account - something that you can't do with various other hosting suppliers on the market.
IonCube in Semi-dedicated Servers
Because all of the semi-dedicated server accounts are created on our advanced cluster platform and ionCube Loader is available on it, you will be able to use any script application which needs this software tool in order to function effectively. With several clicks in your Hepsia hosting Control Panel you'll be able to activate or deactivate ionCube for the PHP version which is currently active for the account. Since we support several releases of PHP concurrently, you'll have to do this each and every time you move to a new version, but when you revert back to a version which you've already used, our system will remember your choice and ionCube Loader will already be activated. If you have several websites in the same account and they require different versions of PHP, you can create a php.ini file in each domain folder and with several lines of program code you are able to define both the PHP release and the status of ionCube regardless of what is selected for the hosting account altogether.